Warning: require(includes/languages/.php) [function.require]: failed to open stream: No such file or directory in

Al cambiarnos a alguna de las nuevas versiones de osCommerce es común que nos encontremos con un error como el siguiente: Warning: require(includes/languages/.php) [function.require]: failed to open stream: No such file or directory in… o en su defecto observemos una pagina en blanco al intentar visualizar nuestra pagina de manera publica.

Este error suele suceder al migrar de una versión anterior todos los datos hacia la nueva.

Las soluciones son:

1_ Y antes que nada, favor de revisar en su administrador que el idioma Español (o el que tenga su tienda) este seleccionado como predeterminado!

2_ Si aun asi el error persiste despues de aplicar el paso 1, entonces sera necesario ingresar en includes/aplication_top.php

Buscar:

// set the language
if (!tep_session_is_registered(‘language’) || isset($HTTP_GET_VARS['language'])) {

Cambiar por:
// set the language
if (!tep_session_is_registered(‘language’) || isset($HTTP_GET_VARS['language']) || empty($language)) {

Esta solución debe terminar con el problema. Si no es asi, entonces contactenos por privado para cotizarle un trabajo mas detallado y profesional.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *